No puedo arrancar Windows y Linux en Grub

Hola a todos. Desde hace muchos años que vengo usando Lubuntu 16 y Windows 7 en mi notebook. Al principio todo iba bien en el grub, pero luego empezaron algunos problemas.

Al hacer un reinicio o encender la PC, al escoger la opcion “ubuntu”, el grub se reiniciaba varias veces hasta que cargaba la imagen de inicio. La unica manera de entrar rapidamente era con “opciones avanzadas” y seleccionar la imagen con el kernel mas actual.

Hace unos meses, actualice a Lubuntu 18 LTS. Como tengo problemas de internet y electricidad en mi comunidad, al principio no se descargo todo y luego se apago la PC por fallo de electricidad. Logre resolver todo el problema haciendo reparaciones de dpkg, y sudos update y upgrade.

Luego todo bien con el Grub, la opcion de “ubuntu” tardaba pero iniciaba. Hace una semana, volvi a actualizar el kernel a v4.15.0-129 y volvieron los problemas. No podia entrar a Lubuntu por ningun medio, ni con la opcion “ubuntu” ni en “opciones avanzadas” escogiendo la v129 ó 128.

Hoy decidi hacer de nuevo otro update && upgrade entrando en Lubuntu desde el “super grub2 rescue” en modo liveCD. Ahora no me reconoce Windows 7, y para colmo, sigue teniendo el mismo problema de arranque con Lubuntu.

Ya he intentado varias soluciones:

1- Hacer los sudos update && upgrade 2- Entrar en terminal y hacer los update-grub 3- Instale Grub2 pero sigue sin reconocer Windows (ni siquiera los memtest reconoce) 4- He montado todas las particiones desde Nautilus, pero igual no las reconoce. Tampoco funciona OS-prober. 5- Instale Boot-repair y me da el mensaje “detectado Windows Legacy, configure su Bios para modo legacy y use esta aplicacion desde un liveCD”. Cosa que me hace gracia, porque antes los reconocia a todos por igual.

No me quiero meter con la Bios, porque recuerdo que esta Notebook vino con el SO “canaima” instalado, y al cambiar algunos parametros para instalar Windows, se me daño la Bios y tuve que flashear.

Recuerdo que una vez hace mucho tiempo creo haber tenido el mismo problema y la solucion fue borrar el grub y volver a instalarlo, pero no consigo ningun tutorial para hacerlo.

Saludos y les agradezco de antemano cualquier ayuda brindada.