Api-ms-win-crt-runtime-|1-1-0.dll

Instale un programa y a la hora de iniciarlo sale esto:

Captura

Descargo esta actualizacion para Windows 7: Windows6.1-KB2999226-x86

Pero al ejecutar sale esto:

Captura2

Para poder aplicar esa actualización necesitas el software base al que se aplica, en este caso creo recordar que es Visual C++ Runtime Redistributable para Visual Studio x64, revisiones de la 2008 a la 2017.

Los que yo tengo son estos…

En todo caso como hago hay? y es necesario los anteriores al del 2017 o con solo tener el ultimo basta?

PD: Windows 7 Ultimate 32bits

Ahí solo veo revisiones x86, necesitas las x64 si tu sistema es de 64 bits a demás de la version mas reciente de Visual Studio.

Normalmente la mayoría de programas suelen avisar de todo lo que necesitan para funcionar y dar la opción de instalarlo junto a ellos.

Tengo 32 bits por eso es que son x86.

Este seria el correcto? https://visualstudio.microsoft.com/es/downloads/?rr=https%3A%2F%2Fsupport.microsoft.com%2Fes-mx%2Fhelp%2F2977003%2Fthe-latest-supported-visual-c-downloads

Recuerda que el error es este:

Si, esa sería la versión adecuada.

Estas usando según ese mensaje un paquete de instalación independiente, si tienes problemas para localizar la actualización vía Windows Update o el mismo no te funciona correctamente Microsoft tiene un procedimiento para repararlo:

https://support.microsoft.com/es-es/help/976275

ok me sale esto:

Tengo que instalar eso para que no me salga mas el error? o ya esta resuelto?

Eso tendrás que verificarlo tu, si el error ya no te aparece no es necesario que instales Visuial Studio como tal, con las revisiones redistributables bastaría.

Pero cual seria el mas idóneo para mi problema, porque como se ve en la imagen hay 3 tipos de Visual Studio, es para una pc de casa, la utilizo para juegos, internet y mas

Versión Community debería ser suficiente.

Si me dices que aplicación es la que te avisa de esas dependencias faltantes igual puedo darte información adicional.

Cuales opciones deberia marcar…

Antes de continuar… partimos de la base de que tu sistema operativo tiene al menos el SP 1 instalado ¿No?

Porque si no es así vas a tener que instalar mas de 200 actualizaciones antes de poder tener las dependencias de Visual C debidamente funcionales.

Este tema se cerró automáticamente 2 días después del último post. No se permiten nuevas respuestas.